Compiling with --enable-shared --disable-library-vanilla

Mikhail Glushenkov the.dead.shall.rise at
Thu Nov 7 12:01:43 UTC 2013

Hi Peter,

On Thu, Nov 7, 2013 at 10:49 AM, Peter Simons <simons at> wrote:
> Hi guys,
> I'm experimenting with shared library support for Haskell in NixOS. So far,
> --enable-shared works great, but it comes at the cost of doubling the build
> times. So I tried to disable building of static libraries to fix that:
>   $ cabal configure --enable-shared --disable-library-vanilla
>   Resolving dependencies...
>   Configuring funcmp-1.8...
> But these build won't succeed, because the in-place registration procedure
> can't find any *.hi files:
>   [...]
> Is anyone aware of a simple remedy for this issue? Has anyone else tried
> this before? Can Haskell libraries be built shared-only?

This is likely a bug in Cabal, please file a ticket on the bug

()  ascii ribbon campaign - against html e-mail
/\   - against proprietary attachments

More information about the cabal-devel mailing list