A package does not install in Windows, but it should

Daniel Díaz Casanueva dhelta.diaz at gmail.com
Wed Jul 3 23:27:26 CEST 2013

Hello everyone.

Firstly, my apologies if this is not the right place to report this
problem, but my guess is that is a cabal related problem.

I wrote a package and is now uploaded in Hackage [1]. I do not have any
problems installing it (cabal install) in my usual computer (debian). I
tried other computer running windows, and it does not build reporting the
following error:

hatex-guide- failed while unpacking the package. The exception was:
user error (Invalid file name in tar archive:

I am using a custom script and this module here (Text.LaTeX.Guide.Aux) is
generated by the Setup.hs code.

Suspecting that it may fail in other computers as well, I have tried to
install it in yet another maching (ubuntu). It installed just fine.

Therefore, I am seeing different behaviors depending on the system, when
the library really does not use any platform specific feature. It should be
portable if I am not missing anything. Anyway, note that the error is
"while unpacking the package". Mysterious to me.

I would gladly look through the Cabal code and look in which step is the
error thrown, but I am not familiarized with the code of the library and it
may be a big task for such a simple (in appearance) error. However, I can
tell that I didn't try (yet).

Any help is appreciated.

Daniel Díaz.


[1] http://hackage.haskell.org/package/hatex-guide
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/cabal-devel/attachments/20130703/38a32acf/attachment.htm>

More information about the cabal-devel mailing list