Sterner warning about breakage with --force-reinstalls?

Roman Cheplyaka roma at
Mon Jan 14 23:40:59 CET 2013

* Daniel Fischer < at> [2013-01-14 23:34:43+0100]
> Maybe
> Warning: The following packages are likely to be broken by the reinstalls:
> ...
> Use --force-reinstalls if you want to install anyway.
> is a bit too inviting for new users, cf.
> package
> Perhaps it should read "if you really know what you're doing" or some such.

I don't think it should, considering that we cannot propose any good
alternative at the moment.

What should that poor user do if she doesn't know what she's doing?

Breaking installed packages offers at least some chance to succeed.


More information about the cabal-devel mailing list