testing cabal-install-0.25.2 with ghc-7.6.1

Mikhail Glushenkov the.dead.shall.rise at gmail.com
Sat Sep 15 04:35:51 CEST 2012

Jens Petersen <juhp <at> community.haskell.org> writes:

> Hi,
> I managed to build cabal-install-0.25.2 (from the cabal-1.16 branch)
> with ghc-7.6.1 Cabal.
> However the use of viewAsFieldDescr in
> cabal-install/Distribution/Client/Config.hs
> causes problems due to the:
>   error "Command.optionToFieldDescr: feature not implemented"

Can it be so that ghc-7.6.1 ships with an older snapshot of Cabal-1.16?
Try building cabal-install using revision 

More information about the cabal-devel mailing list