Hackage 2

Ross Paterson ross at soi.city.ac.uk
Mon Sep 3 16:38:19 CEST 2012

A few minor issues:

In Hackage 1 packages can be deprecated, optionally indicating a
recommended replacement (the "deprecated" and "superseded by" fields of
the per-package "tags" file), e.g. partial-lens and binary-strict-0.3.1.
These don't seem to be in Hackage 2.

Several packages lack documentation.  They don't say why (an issue in
itself), but it appears to be libraries that interface to C libraries,
and libraries included with GHC.  There's little to be done about the
former, but it's really useful to have the documentation of the GHC
libraries there too.  The base package can't be built outside the GHC
tree, but I think it warrants special treatment.

The package her-lexer-0.1 shows links to documentation, but they lead
to an error message.

More information about the cabal-devel mailing list