cabal-install-ghc74 fixes

Ben Millwood haskell at
Sat May 26 22:19:53 CEST 2012

On Sat, May 26, 2012 at 7:32 PM, xemdetia . <xemdetia at> wrote:
> Greetings,
> I was doing a clean, from scratch install of ghc-7.4.1 and was trying
> to get cabal-install to work, and since I am new I tried to do all the
> stuff myself. After failing and starting over I saw this
> package (cabal-install-ghc74) and gave it a shot. Unfortunately with a
> fresh install there are three things wrong.


As far as I can tell, cabal-install-ghc74 is not an official
distribution, it's maintained by someone unrelated to the Cabal team
(and hence possibly not on this mailing list). Furthermore, it says at
the top of its description page "Don't complain if it does not work
for you", so I imagine your time might be better spent talking more
about why your first attempt failed :)

For reference, the official cabal-install package is here: and I'm using
cabal-install-0.14.0 with ghc-7.4.1 fine here, although I admit I
don't remember if I installed it with that version of ghc (I seem to
have several nowadays).

More information about the cabal-devel mailing list