cabal-install-ghc74 fixes

xemdetia . xemdetia at
Sat May 26 20:32:06 CEST 2012


I was doing a clean, from scratch install of ghc-7.4.1 and was trying
to get cabal-install to work, and since I am new I tried to do all the stuff myself. After failing and starting over I saw this
package (cabal-install-ghc74) and gave it a shot. Unfortunately with a
fresh install there are three things wrong.

1. It was not checking for the right .cabal file.
2. network- has the restriction of base <4.5, ghc-7.4.1 ships
with base 4.5 so fails. Using the latest version
( at time of writing) solved that issue.
3. HTTP-4000.1.2 has the same restriction as the previous (base <4.5).
I just used HTTP-4000.2.3 instead.

This builds cabal correctly on my x86_64 Debian stable box.

I don't know how I am supposed to do this, but I just attached a diff
if that helps.


=== BEGIN DIFF ===

< NETWORK_VER=""; NETWORK_VER_REGEXP="2\."       # == 2.*
> NETWORK_VER=""; NETWORK_VER_REGEXP="2\."       # == 2.*
< HTTP_VER="4000.1.2";   HTTP_VER_REGEXP="4000\.[01]\." # == 4000.0.*
|| 4000.1.*
> HTTP_VER="4000.2.3";   HTTP_VER_REGEXP="4000\.2\."    # == 4000.2.*
< grep "cabal-install-ghc72" ./cabal-install-ghc72.cabal > /dev/null 2>&1 \
> grep "cabal-install-ghc74" ./cabal-install-ghc74.cabal > /dev/null 2>&1 \

=== END DIFF ===

PS: There are a lot of emacs temp files (~) in this tarball as well. I
don't know what the policy is on removing them or if anyone cares.

More information about the cabal-devel mailing list