[Hackage] #933: cabal configure doesn't suggest cabal install --only-dependencies

Hackage cvs-ghc at haskell.org
Wed Mar 14 09:24:31 CET 2012

#933: cabal configure doesn't suggest cabal install --only-dependencies
  Reporter:  guest          |        Owner:          
      Type:  enhancement    |       Status:  new     
  Priority:  normal         |    Milestone:          
 Component:  Cabal library  |      Version:
  Severity:  normal         |     Keywords:          
Difficulty:  unknown        |   Ghcversion:          
  Platform:                 |  
 When running 'cabal configure' on a package that has missing dependencies,
 cabal fails to point out that the dependencies can be installed by running

 cabal install --only-dependencies

 When cabal is used by millions of programmers, this will cause $1bn in
 lost productivity.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/933>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list