[Hackage] #666: configure should warn about using base 3

Hackage cvs-ghc at haskell.org
Fri Sep 24 17:05:57 EDT 2010

#666: configure should warn about using base 3
  Reporter:  duncan         |        Owner:         
      Type:  defect         |       Status:  new    
  Priority:  normal         |    Milestone:         
 Component:  Cabal library  |      Version:
  Severity:  normal         |     Keywords:         
Difficulty:  normal         |   Ghcversion:         
  Platform:                 |  
Changes (by benmachine):

 * cc: haskell@… (added)


 As of base-, Prelude is deprecated, so we get warnings while
 building anyway. I'd suggest this ticket can be closed unless we want to
 talk more generally about giving warnings when preferences are applied, or
 perhaps when version upper bounds are missing.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/666#comment:1>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list