[Hackage] #691: cabal-install broken after update of cabal-install

Hackage cvs-ghc at haskell.org
Sat May 22 09:54:18 EDT 2010

#691: cabal-install broken after update of cabal-install
  Reporter:  guest               |        Owner:                   
      Type:  defect              |       Status:  new              
  Priority:  normal              |    Milestone:  cabal-install-0.8
 Component:  cabal-install tool  |      Version:          
  Severity:  major               |     Keywords:                   
Difficulty:  unknown             |   Ghcversion:  6.12.1           
  Platform:  Mac OS              |  
 After I upgraded to a newer cabal-install my cabal-install broke again: I
 get a Bus Error when doing "cabal update" or "cabal install something".
 The version that was bundled with the Haskell platform worked fine, but
 now it's broken again. I'm not sure what it was that went wrong or how to
 debug this.

 The previous time I had Bus Errors I upgraded to the newest available
 Haskell Platform release and started from scratch. I would prefer not to
 do that again. However, I don't really know how to solve the Bus Error.
 Does anyone have a clue where to start? Or is there a way to undo my
 cabal-install upgrade?

 Here is some info about my system (on OSX 10.6):

 ghc -v
 Glasgow Haskell Compiler, Version 6.12.1, for Haskell 98, stage 2 booted
 by GHC version 6.10.4

  cabal --version
 cabal-install version 0.8.0
 using version of the Cabal library

 I'm happy to help debugging and willing to test out possible solutions.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/691>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list