[Hackage] #632: After updating cabal-install Zlib incompatible version

Hackage trac at galois.com
Thu Feb 11 05:49:10 EST 2010

#632: After updating cabal-install Zlib incompatible version
  Reporter:  captainCrash        |        Owner:         
      Type:  defect              |       Status:  new    
  Priority:  high                |    Milestone:         
 Component:  cabal-install tool  |      Version:
  Severity:  major               |     Keywords:         
Difficulty:  unknown             |   Ghcversion:         
  Platform:  Mac OS              |  
 When I ran cabal update it suggested that I had to update cabal-install.
 Which I did. Then running cabal update again gave the error:
 > cabal update
 Downloading the latest package list from hackage.haskell.org
 cabal: Codec.Compression.Zlib: incompatible zlib version

 Any other action requiring ZLib also fails. I downloaded a new version of
 cabal itself, untarred it, and cabal installed it. The problem still
 exists. I run ZLib version I have GHC version 6.10.3. And run
 this all on Mac OS X 10.6.3

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/632>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list