Upgrading to cabal-install-0.8.0: messages on Windows

José Pedro Magalhães jpm at cs.uu.nl
Tue Feb 2 02:43:45 EST 2010

Hello all,

When updating my cabal-install to work with ghc-6.12, I got:

> cabal configure
> cabal: This version of the cabal program is too old to work with ghc-6.12+.
> You will need to install the 'cabal-install' package version 0.8 or higher.
> If you still have an older ghc installed (eg 6.10.4), run:
> $ cabal install -w ghc-6.10.4 'cabal-install >= 0.8'
> > cabal install -w ghc-6.10.4 'cabal-install >= 0.8'
> cabal: "'cabal-install" is not valid syntax for a package name or package
> dependency.
> > cabal install -w ghc-6.10.4 "cabal-install >= 0.8"
> cabal: Cannot find the program 'ghc' at 'ghc-6.10.4' or on the path
> > cabal install -w c:\ghc\ghc-6.10.4\bin\ghc "cabal-install >= 0.8"
> Resolving dependencies... (...)

Then all worked fine. Note that I had ghc-6.12.1 on the PATH and this is
Windows XP 64bit. I found the first message rather informative, but
unfortunately the command given does not work on Windows in general, as far
as I know. For starters, the shell doesn't seem to like single quotes, but
moreover, the full path to the ghc binary has to be supplied, as no symbolic
links such as "ghc-6.10.4" are available. Perhaps these messages could be
updated to be more helpful to Windows users?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/cabal-devel/attachments/20100202/c7b60877/attachment-0001.html

More information about the cabal-devel mailing list