cabal-install for ghc 6.12 rc1

Duncan Coutts duncan.coutts at
Tue Oct 20 08:02:43 EDT 2009

On Tue, 2009-10-20 at 10:49 +0100, Robin Green wrote:

> Uh-oh. This looks like a big chunk of work (the package index type is
> no longer polymorphic in cabal 1.8.0).

Yes. Installed packages are no longer identified by a PackageId, they're
now identified by a separate InstalledPackageId and there can be
multiple installed packages with the same PackageId. The impact on
cabal-install is non-trivial.

> Has anyone else worked on this? Is there some secret branch of
> cabal-install somewhere that works on ghc 6.12?

I have some incomplete patches locally. I've been a bit pressed for time
recently however.


More information about the cabal-devel mailing list