Request to make a validation item on the hackage uploader a soft warning rather than a hard fail

Andrea Vezzosi sanzhiyan at
Wed Mar 4 18:35:42 EST 2009

We resolved to drop support for Cabal < 1.4 in happstack, most users
will install using cabal-install anyway.

Thanks, Andrea Vezzosi.

On Wed, Mar 4, 2009 at 11:52 PM, Matthew Elder <matt at> wrote:
> Hello All,
> I am trying to upload a release package for happstack 0.2. Right now it
> gives me an error because I added dist/build/autogen to my hs-source-dirs.
> You can find the output of my error here:
>  I have been working with Andrea Vezzossi (Saizan) to try to figure out the
> best way to handle this situation; he says that this must stay in the .cabal
> file to be compatible with Cabal (version that ships with ghc
> 6.8.3). Is there any way you guys could make this a soft fail when uploading
> to hackage rather than a hard fail? This seems reasonable at least for
> awhile until everyone has a chance to upgrade to the latest versions of ghc.
> Thanks in advance guys!
> --
> Need somewhere to put your code?
> Want to build a webapp?

More information about the cabal-devel mailing list