Cabal install broken with GHC 6.10.1.* HEAD

Duncan Coutts duncan.coutts at
Thu Feb 26 19:14:53 EST 2009

On Thu, 2009-02-26 at 11:13 +0000, Neil Mitchell wrote:
> Hi,
> I've just installed GHC which has set base as
>, instead of the which GHC 6.10.1 had (I think).

Note that both ghc-6.10.1 and the current darcs version of the
ghc-6.10.x branch come with base See:

> This causes cabal install to break, as it implicitly adds
> base == which nothing has so nothing installs.

There's something else going on. cabal-install does know about the base
package but does not have any hard coded versions. The only constraint
it places on base is that the dependency solver must pick an installed
version of base (ie and not try to install from sources off hackage).

> Could a new version of cabal install be released that fixes this?

We'll need more details to work out what the problem is. Could you
describe the symptoms in more detail. See also if ghc-pkg check reports


More information about the cabal-devel mailing list