Cabal install broken with GHC 6.10.1.* HEAD

Neil Mitchell ndmitchell at
Thu Feb 26 06:13:57 EST 2009


I've just installed GHC which has set base as, instead of the which GHC 6.10.1 had (I think). This
causes cabal install to break, as it implicitly adds base ==
which nothing has so nothing installs.

Could a new version of cabal install be released that fixes this? I'm
totally hooked on cabal install and now having upgraded GHC I've lost
it. The likely result is that I'll have to downgrade my GHC because
cabal is just too useful!



More information about the cabal-devel mailing list