[Hackage] #491: "cabal configure" does not install dependencies

Hackage trac at galois.com
Sat Feb 7 14:08:51 EST 2009

#491: "cabal configure" does not install dependencies
  Reporter:  SamB                |        Owner:       
      Type:  defect              |       Status:  new  
  Priority:  normal              |    Milestone:       
 Component:  cabal-install tool  |      Version:  HEAD 
  Severity:  normal              |     Keywords:       
Difficulty:  unknown             |   Ghcversion:  6.8.2
  Platform:                      |  
 After typing {{{M-x compile RET cabal configure -p && cabal haddock
 --hyperlink-source --executables}}}, instead of the expected slew of
 warnings, I got just:

 cabal configure -p && cabal haddock --hyperlink-source --executables
 Resolving dependencies...
 Configuring lhc-0.6.20090126...
 setup: At least the following dependencies are missing:
 value-supply -any && -any

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/491>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list