[Hackage] #331: pkg-config error messages could be better

Hackage trac at galois.com
Tue Dec 22 11:22:50 EST 2009

#331: pkg-config error messages could be better
  Reporter:  duncan         |        Owner:                     
      Type:  defect         |       Status:  new                
  Priority:  normal         |    Milestone:                     
 Component:  Cabal library  |      Version:            
  Severity:  normal         |   Resolution:                     
  Keywords:                 |   Difficulty:  very easy (<1 hour)
Ghcversion:  6.8.2          |     Platform:                     
Comment (by joe):

 Replying to [comment:2 duncan]:
 > They've probably never heard of pkg-config and do not know what it does.

 True.  (I did not.)  But phrasing it as "pkg-config --modversion" gives
 the user the hint that it's an executable (with a man page).  The long
 version would have pointed me in the right direction too.  Either way, I
 think it's worthwhile to cite the exact command Cabal ran.  This gives the
 user a starting place for troubleshooting if there is a problem with the
 user's system installation or they're on an unusual platform, eg.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/331#comment:3>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list