cabal-install fails on WinXP

Duncan Coutts duncan.coutts at
Thu Apr 16 03:49:00 EDT 2009

On Wed, 2009-04-15 at 14:17 +0100, Alistair Bayley wrote:
> I've tried using cabal-install (cabal.exe) for the first time to
> install yi, and all of the packages fail to download. Reducing to a
> simple test case, "cabal install binary" fails with:
> Resolving dependencies...
> Downloading binary-0.4.4...
> cabal: Error: some packages failed to install:
> binary-0.4.4 failed while downloading the package.
> Where do I look to diagnose this?


cabal fetch binary -v3

It should give you plenty of detail on the HTTP conversation. Could you
also file a ticket pointing out how useless the default error message is
when the download fails. We should at least tell the user the HTTP error


More information about the cabal-devel mailing list