error with package ghc-6.10.1 and its dependency on process-1.0.1.[01]

Duncan Coutts duncan.coutts at
Sat Nov 22 12:51:01 EST 2008

On Fri, 2008-11-21 at 15:42 +0000, allan wrote:
> Dear all
> I'm attempting to install the latest haddock version via 'hackage' and I'm getting the error:
> Resolving dependencies...
> cabal: dependencies conflict: ghc-6.10.1 requires process == however
> process- was excluded because ghc-6.10.1 requires process ==
> I tried re-installing ghc, but I get the same problem.
> Any suggestions?

Hmm, that's odd. It makes it look like the ghc api package depends on
two different versions of the process library.

The output of "cabal install -v haddock" might give us more of a hint.
That and "ghc-pkg field ghc depends"


More information about the cabal-devel mailing list