[Hackage] #395: Warn about dependencies like parsec <=

Hackage trac at galois.com
Tue Nov 11 06:30:30 EST 2008

#395: Warn about dependencies like parsec <=
  Reporter:  duncan         |        Owner:                     
      Type:  enhancement    |       Status:  new                
  Priority:  normal         |    Milestone:                     
 Component:  Cabal library  |      Version:                     
  Severity:  normal         |   Resolution:                     
  Keywords:                 |   Difficulty:  very easy (<1 hour)
Ghcversion:  6.8.3          |     Platform:                     
Comment (by guest):

 quote: {{{foo < 2.0.0}}} is weird. It says {{{foo-2.0}}} is ok, but
 {{{foo-2.0.0}}} is not.

 It is only weird because Data.Version has weird semantics for equality.
 Most people expect 2.0 to be the same version as 2.0.0 and  If we
 were to adopt the proposal to fix Data.Version so that these were truly
 equal, then the weirdness would disappear.

 (But I agree that a dependency like {{{foo <= 2.0}}} is definitely still

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/395#comment:1>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list