[Hackage] #395: Warn about dependencies like parsec <=

Hackage trac at galois.com
Sat Nov 8 10:12:28 EST 2008

#395: Warn about dependencies like parsec <=
  Reporter:  duncan               |        Owner:       
      Type:  enhancement          |       Status:  new  
  Priority:  normal               |    Milestone:       
 Component:  Cabal library        |      Version:       
  Severity:  normal               |     Keywords:       
Difficulty:  very easy (<1 hour)  |   Ghcversion:  6.8.3
  Platform:                       |  
 Cabal should warn about dependencies like `parsec <=`. It's almost
 certainly a mistake given the conventional semantics of version numvers.

 Something like `foo <  2.0` is quite common and it's relatively harmless
 so there's probably no point in warning. On the other hand `foo < 2.0.0`
 is weird. It says `foo-2.0` is ok, but `foo-2.0.0` or `foo-` is

 Something like `foo <= 2.0` is a definately weird though since it excludes
 bug fixes like `foo-`

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/395>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list