[Hackage] #265: Cabal field stability not useful

Hackage trac at galois.com
Sat May 3 08:44:57 EDT 2008

#265: Cabal field stability not useful
  Reporter:  guest          |        Owner:         
      Type:  defect         |       Status:  new    
  Priority:  normal         |    Milestone:         
 Component:  Cabal library  |      Version:
  Severity:  normal         |   Resolution:         
  Keywords:                 |   Difficulty:  normal 
Ghcversion:  6.8.2          |     Platform:         
Comment (by duncan):

 Ah, I mean something like the
 [http://haskell.org/haskellwiki/Package_versioning_policy package
 versioning policy]. It would be useful for packages to opt-in and declare
 that they follow the versioning policy. It provides similar information to
 the stability field but it's more precise and more useful. It also gives
 us the potential to check that packages that following the versioning
 policy really  are doing so.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/265#comment:3>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list