[Hackage] #226: Cabal install should upgrade in the correct order.

Hackage trac at galois.com
Thu Jan 31 10:57:48 EST 2008

#226: Cabal install should upgrade in the correct order.
  Reporter:  guest               |        Owner:        
      Type:  enhancement         |       Status:  new   
  Priority:  normal              |    Milestone:        
 Component:  cabal-install tool  |      Version:  HEAD  
  Severity:  normal              |   Resolution:        
  Keywords:                      |   Difficulty:  normal
Ghcversion:  6.8.2               |     Platform:        
Comment (by duncan):

 See also #198 about the behaviour of upgrade and install.

 Note also that the install error recovery is very simple minded. Currently
 if a package fails we continue to try to build the remaining packages and
 then report them as failures too. We should keep the package dep graph and
 remove packages that depended on the failing one rather than trying to
 build them anyway. So that means maintaining a dep graph while building,
 not just immediately flattening to a topological order.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/226#comment:1>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list