duncan.coutts at worc.ox.ac.uk
Mon Dec 22 06:19:04 EST 2008
On Mon, 2008-12-22 at 09:45 +0000, Neil Mitchell wrote:
> I have base == 4.0.* in my hlint cabal file
> (http://www.cs.york.ac.uk/fp/darcs/hlint/hlint.cabal). Does that
> require Cabal 1.4 or 1.6? Apparently 1.2 fails to parse it, but with a
> cabal-version >= 1.2 declaration I don't get any warnings from Cabal
> 1.6. So what is the minimum verison for the version wildcard,
> and why doesn't cabal warn me I got it wrong?
Because I only added the check in the development version a couple weeks
ago. It changes the representation of the VersionRange type to
distinguish the wildcard in the abstract syntax so it cannot be pushed
into the 1.6.x branch. However hackage can start using it immediately
with just a re-compile and that will prevent people uploading packages
with this mistake.
More information about the cabal-devel