Wildcard syntax

Neil Mitchell ndmitchell at gmail.com
Mon Dec 22 04:45:50 EST 2008


I have base == 4.0.* in my hlint cabal file
(http://www.cs.york.ac.uk/fp/darcs/hlint/hlint.cabal). Does that
require Cabal 1.4 or 1.6? Apparently 1.2 fails to parse it, but with a
cabal-version >= 1.2 declaration I don't get any warnings from Cabal
1.6. So what is the minimum verison for the version wildcard, and why
doesn't cabal warn me I got it wrong?



More information about the cabal-devel mailing list