Can't create sdist bundle

Duncan Coutts duncan.coutts at
Tue Nov 13 05:12:05 EST 2007

On Mon, 2007-11-12 at 17:50 +0000, Neil Mitchell wrote:
> Hi,
> Long time problem, now with a new version of GHC and Cabal, and still
> a problem...

> Calling tar then gzip would make this work. This bug stops me from
> updating my Hackage packages which won't work with GHC 6.8.1.

Well the simple solution is to change the version of tar.exe you've got
to one that does support gzip. I'm sure there must be one. Changing
Cabal about to call separate tar and gzip might make it work on your box
but since no other Windows users have tar or gzip anyway it won't help

The right solution imho is to move the sdist feature into cabal-install
where it can depend on the tar and zlib packages. Then it'd work without
requiring tar.exe or gzip.exe on your path. It already does this for
unpacking tarballs and works fine on windows.


More information about the cabal-devel mailing list