[Hackage] #174: cabal-install tries to upgrade the base package

Hackage trac at galois.com
Mon Nov 12 08:32:26 EST 2007

#174: cabal-install tries to upgrade the base package
  Reporter:  duncan         |        Owner:         
      Type:  defect         |       Status:  new    
  Priority:  normal         |    Milestone:         
 Component:  cabal-install  |      Version:
  Severity:  normal         |   Resolution:         
  Keywords:                 |   Difficulty:  normal 
Ghcversion:  6.6            |     Platform:  Linux  
Comment (by guest):

 There are a number of issues here:

  * base should not be in HackageDB, since it is impossible to upgrade it.
  * The cgi package has been updated to use configurations to work with
 both base-2 and base-3, but fastcgi hasn't (it is updated in darcs, I just
 haven't gotten around to uploading it).
  * cabal-install picks the first working configuration. This has the
 result that fastcgi which dependes on base >= 2.0 is configured to use the
 ''installed'' base-2.1.1, and cgi which can use either base version is
 configured to use the ''available'' base-3.0.0.  If base was not in
 HackageDB, cgi would be configured correctly.

 There is a bug here, but it is not that configurations are flattened
 incorrectly. Rather, the problem is that cabal-install does not backtrack
 in the dependency resolution if it encounters an uninstallable package.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/174#comment:4>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list