[Hackage] #174: cabal-install tries to upgrade the base package

Hackage trac at galois.com
Mon Nov 12 07:33:52 EST 2007

#174: cabal-install tries to upgrade the base package
  Reporter:  duncan         |        Owner:         
      Type:  defect         |       Status:  new    
  Priority:  normal         |    Milestone:         
 Component:  cabal-install  |      Version:
  Severity:  normal         |   Resolution:         
  Keywords:                 |   Difficulty:  normal 
Ghcversion:  6.6            |     Platform:  Linux  
Comment (by duncan):

 Replying to [comment:2 ross at soi.city.ac.uk]:
 > Maybe base- should be removed from HackageDB.

 I don't think that is the problem. Look at the output of cabal info, it
 thinks cgi depends on two versions of the base lib. It's just flattening
 the configurations incorrectly.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/174#comment:3>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list