"Setup.lhs: hope.cabal has been changed, please re-configure."

Peter Gammie peteg42 at gmail.com
Wed Dec 19 09:53:49 EST 2007

On 19/12/2007, at 9:00 PM, Malcolm Wallace wrote:

>> In the case of HaXml use the 1.13.3 version was updated to use the  
>> new
>> split base libs but not to use configurations so it would also build
>> with ghc-6.6. Hopefully we can persuade Malcolm to upload a .4 that
>> uses configurations and works with both.
> I have actually tried to use configurations for HaXml's cabal file,  
> but
> I'm a bit stuck.  I don't know what the library dependencies for  
> various
> older versions of ghc are, and I don't know how to find out, short of
> installing several versions of ghc, upgrading their Cabal to 1.2, and
> guessing dependencies until it builds.
> Got any good hints?

I don't, but I believe Bjorn does. Here's some stuff from Hope that  
might help.

<standard copyright, author, etc. boilerplate>

Flag bytestring-in-base
Flag split-base

     <usual stuff, no base>
   if flag(bytestring-in-base)
     -- bytestring was in base-2.0 and 2.1.1
     Build-depends: base >= 2.0 && < 2.2
     -- in base 1.0 and 3.0 bytestring is a separate package
     Build-depends: base < 2.0 || >= 3, bytestring >= 0.9
   if flag(split-base)
     Build-depends: base >= 3.0, containers, random, directory, old- 
time, old-locale
     Build-depends: base < 3.0
     <same old>
     <same old>
   Ghc-options: <same old>

If you try it out under whatever GHC you've got, I'll try it out under  
a fairly vanilla GHC 6.6.1 and the latest Cabal. I think everything  
you depend on (except polyparse, what's that?) is in the old "base". I  
will repair it if not.


More information about the cabal-devel mailing list