[Haskell-beginners] cabal install local troubles (osx)

luc taesch luc.taesch at gmail.com
Sun Mar 31 22:41:08 CEST 2013

On Osx 10.8, I recently run into 32/64 issues.
so I was advised to reinstall HP 2012.4 64, which I did.
to be sure, I wiped ( moved) my ./~cabal

after resintallation I was suprised to find it nearly empty, and all 
files are now into ~/Library/Haskell
( and the Path is to be updated accrodingly,as mentionned in the install)

note this only occur when your ~/.cabal is non existing at installation time
as documented below


Haskell Platform 2011.2.0.0 (March 2011) and later uses this layout and 
sets up cabal to use it for built packages. On new installs, if you 
didn't already have a ~/.cabal/config file, then it is set up by 
default. Otherwise, the config file for this layout is placed in 
~/.cabal/config.platform and you can manually move it over, or 
incorporate it into your existing config file.

On 2013-03-27 06:16:53 +0000, Miro Karpis said:

> please, can you help me with following. I have installed haskell on mac 
> from the package. When I check cabal -V I can see 1.14.0 
> That is because the cabal is loading from /Library/Haskell/bin.
> After that I run 'cabal install cabal-install', I get following output:
> Installing executable(s) in
> /Users/miro/Library/Haskell/ghc-7.4.2/lib/cabal-install-
> Updating documentation index /Users/miro/Library/Haskell/doc/index.html
> So the new version of cabal is installed in another place. When I 
> install new package via cabal, it uses the 1.14.0 version. I have tried 
> to copy the new version to bin, but that just didn't help 
> because the new packages have been installed somewhere else.
> Please what is the proper way to fix this?
> many thanks,
> miro

More information about the Beginners mailing list