[Haskell-beginners] cabal install errors & issues

Antoine Latter aslatter at gmail.com
Fri Aug 17 04:36:54 CEST 2012

Oh, I was assuming you already had a version of 'network' installed
that came with the Haskell Platform - the platform comes with:


So I assumed they were being installed again because of the flag.

Really, the platform comes with everything that cabal-dev depends on,
so it might be easier to solve whatever error message you're getting
without the '--force' flag.


On Thu, Aug 16, 2012 at 9:30 PM, Gregory Guthrie <guthrie at mum.edu> wrote:
> Yes, because a simple "cabal install" failed, and said the only way to do it was to force-installs.
> But if this is a dependency, wouldn't it be requires (or not) either way?
> -------------------------------------------
>> -----Original Message-----
>> > Trying to bootstrap into cabal-dev seems to require some external
>> > installations as well;
>> >
>> >     >>cabal install cabal-dev --force-reinstalls
>> Maybe I'm missing some context, but is there a reason you're using the "--fore-reinstalls"
>> flag? If you didn't pass that then 'cabal' maybe would not try to re-install the 'network'
>> package and you wouldn't run into this.

More information about the Beginners mailing list