[Haskell-beginners] install wxHaskell on osx 10.7 64bit

Heinrich Apfelmus apfelmus at quantentunnel.de
Sun Apr 8 09:53:38 CEST 2012

Miguel Negrao wrote:
> Then I get:
> cabal install reactive-banana-wx --constraint=wxcore==0.13.1
> Resolving dependencies...
> cabal: cannot configure reactive-banana-wx- It requires wxcore
> ==
> For the dependency on wxcore == there are these packages:
> wxcore- However none of them are available.
> wxcore- was excluded because of the top level dependency wxcore
> ==0.13.1

I have hardcoded the  wxcore==  constraint in the 
reactive-banana-wx  package because I didn't take the time to fix my 
installation problems with the newer wx package yet.

You can override this by downloading the tarball from hackage and 
changing the dependency in  reactive-banana-wx.cabal  from

    build-depends: wxcore ==

to the version you desire. Same for the wx == .. constraint. Then, 
simply type

    cabal install

to install from the  *.cabal file in your current directory.

Best regards,
Heinrich Apfelmus


More information about the Beginners mailing list