[Haskell-beginners] Re: Cygwin error: D:\Haskell\bin/windres: can't open temporary file `\/cca02652.irc': No such file or directory

remy willems steen.reem at gmail.com
Thu Mar 25 16:53:56 EDT 2010

I'm trying to install the package directory from cygwin. I am a windows user
and have tried to use "cabal install directory" from the windows prompt but
that quickly gives an error about a missing tool.
I'm using cygwin to install directory now. However I still get an error. The
error is:

* Missing header file: HsDirectory.h
This problem can usually be solved by installing the system package that
provides this library (you may need the "-dev" version). If the library is
already installed but in a non-standard location then you can use the flags
--extra-include-dirs= and --extra-lib-dirs= to specify where it is.

I have searched for this file and found it in the
"Haskell\directory1.0.1.0\include" folder. I googled the error and found
something about adding #include <sys/types> to the file. The "HsDirectory.h"
file already contains "#include <sys/types>".
What should I do?
Many thanks,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/beginners/attachments/20100325/9ad1c95b/attachment.html

More information about the Beginners mailing list