[Haskell-beginners] Issues With Install Script in Haskell Platform 2009.2.0.2

aditya siram aditya.siram at gmail.com
Fri Mar 12 19:22:29 EST 2010

Hi all,
I am running Ubuntu Karmic Kameleon and GHC 6.10.4 and am having
issues with the Haskell Platform 2009.2.0.2 source installer.

The 'configure' and 'make' step work fine, but 'make install' errors with:
Installing mtl-
The mtl- script does not exist or cannot be run

And indeed mtl- does not exist. It appears that the
'make' step builds some packages and not others. The 'Setup'
executable is only in the following package directories:

Here is the current contents of my global and local packages:
Global Packages:
    Cabal-, HUnit-, QuickCheck-, array-,
    base-, base-, bytestring-, containers-,
    directory-, (dph-base-0.3), (dph-par-0.3),
    (dph-prim-interface-0.3), (dph-prim-par-0.3), (dph-prim-seq-0.3),
    (dph-seq-0.3), extensible-exceptions-, filepath-,
    (ghc-6.10.4), ghc-prim-, haddock-2.4.2, haskell-src-,
    haskell98-, hpc-, html-, integer-,
    mtl-, network-, old-locale-, old-time-,
    packedstring-, parallel-, parsec-,
    pretty-, process-, random-,
    regex-base-, regex-compat-, regex-posix-,
    rts-1.0, stm-, syb-, template-haskell-,
    time-1.1.4, unix-, xhtml-3000.2.0.1
Local Packages:
    haskelldb-0.13, haskelldb-hsql-0.10, haskelldb-hsql-sqlite3-0.10,
    hsql-1.8.1, hsql-sqlite3-1.8.1

More information about the Beginners mailing list