[Haskell-beginners] Installing packages

Krzysztof Skrzętnicki gtener at gmail.com
Sun Feb 8 18:09:50 EST 2009

On Sun, Feb 8, 2009 at 23:27, Tymur Porkuian <shooshpanchick at gmail.com> wrote:
>>> I'm trying to install wxcore-0.11.0 using Cabal. I've downloaded it
>>> from
>>> http://hackage.haskell.org/cgi-bin/hackage-scripts/package/wxcore-0.11.0,
>>> unpacked and tried to follow instructions from
>>> http://haskell.org/haskellwiki/Cabal/How_to_install_a_Cabal_package,
>>> but this is what I'm getting:
>>> D:\libraries\wxcore-0.11.0>runhaskell Setup configure
>>> Setup: sh: runGenProcess: does not exist (No such file or directory)
>>> What does this mean?
>> On Windows it usually means that the package has a "configure" shell script
>> and therefore requires that Cygwin or MSYS be installed.
> I have installed Cygwin, and still getting the exact same error.
> Should something else be done after installing it?

Are you running "cabal install" from within Cygwin prompt?

All best

Christopher Skrzętnicki

More information about the Beginners mailing list