[arch-haskell] Upgrading to monad-control-0.3

Nicolas Pouillard nicolas.pouillard at gmail.com
Sat Oct 12 07:39:50 UTC 2013

On Mon, Jan 2, 2012 at 7:12 PM, Magnus Therning <magnus at therning.org> wrote:
> On Mon, Jan 02, 2012 at 11:21:22AM +0100, Nicolas Pouillard wrote:
>> Hello,
>> To package the latest and greatest version of git-annex I need to have
>> monad-control-0.3.
>> However this depend on the update of yesod and would break mongoDB as well.
>> I'm quite short on times these days and would like to know if this
>> is gonna happen soon or not?
>> In the meantime I email the author of the mongoDB haskell package.
> It's *very* unlikely to happen.  As you probably noticed yourself any
> update to yesod would necessitate an update of attoparsec to at least
> 0.10, which in turn requires an update to text and text lives in
> [extra].

I didn't remember that this was so constrained. Did someone asked the
maintainer? If there are good reasons to keep one of these packages at
an old version then we should consider having multiple versions of such
packages. I heartly persuaded that while we should keep that at a minimum
we should have some packages at multiple versions.

Nicolas Pouillard

More information about the arch-haskell mailing list