[arch-haskell] Upgrading to monad-control-0.3

Magnus Therning magnus at therning.org
Sat Oct 12 07:39:50 UTC 2013

On Mon, Jan 02, 2012 at 11:21:22AM +0100, Nicolas Pouillard wrote:
> Hello,
> To package the latest and greatest version of git-annex I need to have
> monad-control-0.3.
> However this depend on the update of yesod and would break mongoDB as well.
> I'm quite short on times these days and would like to know if this
> is gonna happen soon or not?
> In the meantime I email the author of the mongoDB haskell package.

It's *very* unlikely to happen.  As you probably noticed yourself any
update to yesod would necessitate an update of attoparsec to at least
0.10, which in turn requires an update to text and text lives in


Magnus Therning                      OpenPGP: 0xAB4DFBA4 
email: magnus at therning.org   jabber: magnus at therning.org
twitter: magthe               http://therning.org/magnus

Perl is another example of filling a tiny, short-term need, and then
being a real problem in the longer term.
     -- Alan Kay
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://www.haskell.org/pipermail/arch-haskell/attachments/20131012/c9a98273/attachment.sig>

More information about the arch-haskell mailing list