[arch-haskell] ghc provides bug? utf8-string 0.3.4

Adam Vogt vogt.adam at gmail.com
Sat Oct 12 07:35:58 UTC 2013

* On Monday, January 25 2010, Don Stewart wrote:

>Something funny is going on (I think GHC shipped an old version of
>utf8-string, which will conflict when we install the one from [extra].
>Anyone know what to do?
>-- Don

It doesn't conflict, and things work out just fine when you install

$ pacman -Q haskell-utf8-string
haskell-utf8-string 0.3.6-2.1

$ ghc-pkg list utf8-string

And I have not run into any problems with packages that depend on
utf8-string-0.3.6 (ex. xmonad), while ghci doesn't seem to have problems
picking a specific version when you load any of the modules provided by
utf8-string (probably it loads the newest, but I have not checked).


More information about the arch-haskell mailing list