[arch-haskell] haskell platform dependencies

Don Stewart dons at galois.com
Sat Oct 12 07:35:36 UTC 2013

> On Tue, Oct 20, 2009 at 12:37 PM, Thomas Girod <thomas at 0xc29.net> wrote:
> > hi there.
> >
> > I ran into some troubles installing haskell-platform today. Specifically,
> > community contained haskell-zlib-, which is too recent, and there was no
> > pkgbuild for haskell-zlib- in AUR.
> >
> > So I'm wondering : can the arch-haskell script maintain a version of all
> > dependencies of the haskell-platform in AUR, so we don't have problems
> > installing it ?
> >
> > Or maybe having a set of pkgbuilds with a name like haskell-zlib-hp to
> > explicitely state that it is the version blessed by the haskell-platform ?
> I guess this is something that has to be worked out only when Haskell
> Platform mandates GHC 6.12.  IIRC that won't happen until next year
> some time.  In the meantime I would recommend that no one uses Haskell
> Platform on Arch!
> I hope that in the (not so) long term Haskell Platform moves into a
> binary repo (like [community] or [extra]).  Then AUR can have more
> bleeding edge versions of the base packages, similar to how some
> packages have -svn/-git versions, maybe we should adopt -hackage as
> suffix?

Why not move it short term. Vegai?

Fedora, Debian already have binary installs of the platform...

More information about the arch-haskell mailing list