[arch-haskell] Switching from community+aur to haskell repo, missed something?

Magnus Therning magnus at therning.org
Thu Apr 11 09:01:57 CEST 2013

On Thu, Apr 11, 2013 at 6:35 AM, Sean Escriva <sean.escriva at gmail.com> wrote:
> I tried to make a clean switch by uninstalling all haskell pkgs+ghc,
> but I missed something so now I'm getting an odd error when I try to
> install xmonad or xmonad-contrib:
> soundwave ~ » sudo pacman -S xmonad
> resolving dependencies...
> looking for inter-conflicts...
> error: failed to prepare transaction (could not satisfy dependencies)
> :: haskell-x11-xft: requires haskell-x11=
> :: haskell-x11-xft: requires haskell-utf8-string=0.3.7-26
> More info on steps leading up to it:
> https://gist.github.com/webframp/bdfa579b5129ae5cd3ef
> I've tried removing every haskell-* package and ghc, and reinstalling,
> no difference.
> What am I missing?

In what order do you have the repos in your pacman conf?  Do note that
[haskell-core] (or [haskell], either still works) should go before


Magnus Therning                      OpenPGP: 0xAB4DFBA4
email: magnus at therning.org   jabber: magnus at therning.org
twitter: magthe               http://therning.org/magnus

More information about the arch-haskell mailing list