[arch-haskell] haskell-safe in [haskell-extra] relies on ghc- ?

Pierre Radermecker pradermecker at yahoo.ca
Fri Dec 7 11:37:04 CET 2012


[haskell] seems to work fine with ghc 7.6.1 (the current ghc version in Arch repos) but my first try with [haskell-extra] has choked:

sudo pacman -S haskell-safe

resolving dependencies...
warning: cannot resolve "ghc=7.4.2-1", a dependency of "haskell-safe"

Actually my sole need is to install hoogle and I am trying to achieve this by using the provided repos. As I quickly realize that manual cabal installs are not a good option, I try to minimize them.
Here I am just a bit surprised that the first package I try from [haskell-extra] fails because it expects another version of ghc ... Am I missing something or is it "haskell-safe" that should be fixed or removed  from the repository ?

 Thanks for your help

- PierreR
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/arch-haskell/attachments/20121207/df8ec419/attachment.htm>

More information about the arch-haskell mailing list