[arch-haskell] How to translate "parsec >= 3.0 || == 2.1.*"?

Rémy Oudompheng remyoudompheng at gmail.com
Mon Jan 3 17:16:52 CET 2011

On 2011/1/3 Peter Simons <simons at cryp.to> wrote:
>  > Maybe I'm being overly simplistic here, but I don't see the problem.
> Well, I'm not sure why this issue appears to be controversial either.
> Personally, I suggested to translate that dependency to "parsec>=2.1.0",
> but no-one seems to agree with me, so I'm trying to figure out a solution
> that we're all happy with.

I perfectly remember agreeing with you on this: I suggested using the
convex hull of possible versions instead of only the first or last
interval, and even sent a patch doing this, should I file a pull
request or commit directly instead ?


More information about the arch-haskell mailing list