[arch-haskell] How to translate "parsec >= 3.0 || == 2.1.*"?

Peter Simons simons at cryp.to
Mon Jan 3 16:52:07 CET 2011

Hi Xyne,

 > If the 2.1.* series is still in the repos then use
 > ('parsec>=2.1.0' 'parsec<2.2').

I don't understand why you propose setting that upper bound. Won't this
restriction mean that the PKGBUILD file will have to be re-generated when
we update to parsec 3? Why do you think that behavior would be desirable?

 > Maybe I'm being overly simplistic here, but I don't see the problem.

Well, I'm not sure why this issue appears to be controversial either.
Personally, I suggested to translate that dependency to "parsec>=2.1.0",
but no-one seems to agree with me, so I'm trying to figure out a solution
that we're all happy with.

 > The real issue seems to be one of feeding this information to cabal2arch.

Actually, I believe that this is a secondary issue right now. We ought to
agree on the desired result before we begin to worry about how to achieve
that result.

Take care,

More information about the arch-haskell mailing list