[xmonad] xmodmap -e "clear mod2" is killing my xmonad mod key

Thomas Løcke thomas.granvej6 at gmail.com
Mon Feb 4 15:45:40 CET 2013

Hey all,

The rollout to my employees are going well. The BETA group are very
satisfied with the setup, and all minor niggles have been sorted out so far.

Except for one thing: Due to a legacy Windows XP application that isn't
playing very nice with VirtualBox, we need to disable the numlock key
completely. What we need is simple:

1. Activate numlock upon login.
2. Disable the numlock key so numlock stays ON under all circumstances

I was convinced that this was easily solved by adding some xmodmap magic to

xmodmap -e "clear mod2"

and while that does indeed disable the key while retaining the ON setting
from my SLiM login manager, it also wreaks havoc on my xmonad mod key,
which no longer works.

I've got my modMask set to mod4Mask. I've tried using the default modMask,
but the problem is still there. I've also tried using numlockx (instead of
SLiM) to set numlock = ON, but that changes nothing: Clearing the mod2 key
still mess up my xmonad. I've tried remapping the numlock keycode to
nothing or to some other key, with no success.

I'm at my wits end.

Thomas Løcke
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/xmonad/attachments/20130204/2d8f465e/attachment.htm>

More information about the xmonad mailing list