[xmonad] Issue 542 in xmonad: MultiToggle.hs Illegal datatype context

codesite-noreply at google.com codesite-noreply at google.com
Wed Apr 17 11:21:13 CEST 2013

Status: New
Owner: ----

New issue 542 by alexandr.romanyuk: MultiToggle.hs Illegal datatype context

Hi guys,
Don't know if its the right place to commit issues for xmonad-contrib. If  
not - please point a link to a right bug-tracker.

What steps will reproduce the problem?
1. cabal install xmonad-contrib

What is the expected output? What do you see instead?

Building xmonad-contrib-0.11.1...
[ 10 of 226] Compiling XMonad.Layout.MultiToggle (  
XMonad/Layout/MultiToggle.hs, dist/build/XMonad/Layout/MultiToggle.o )
XMonad/Layout/MultiToggle.hs:102:6: Illegal datatype context (use  
-XDatatypeContexts): LayoutClass l a =>
cabal: Error: some packages failed to install:

What version of the product are you using? On what operating system?

- Debian Squeeze
- GHC 7.2.1
- xmonad 0.11

Are you using an xmonad.hs?  Please attach it and the output of "xmonad

Please provide any additional information below.

You received this message because this project is configured to send all  
issue notifications to this address.
You may adjust your notification preferences at:

More information about the xmonad mailing list