[xmonad] Focus and shortcuts on some applications

Robert Sawko robertsawko at gmail.com
Mon Oct 8 13:29:37 CEST 2012

Dear All,

I would like to raise two issues and I hope you don't mind if I address
them in two separate e-mails.

First, is the focus and shorcuts in some application. For instance a Java
application Geogebra. When I run it I seem to have focus on it but no
shortcuts work until I actually click on the window. The same happens if
I change focus to another window and then come back. No shortcuts until
I actually click.

The same happens for Scilab. When I run it, I can immediately interact
with its terminal, but when I change focus and focus on Scilab again,
then I actually need to click on the window to start typing in commands. 

Is this a problem of Xmonad or my configuration? Is there anything that
could be done. This "one-click" will not save me a vast amount of time,
but would be great if there was something simple that could be done
about it.

I will be obliged for advice,
One of the greatest intellectual achievements of 20th century:

More information about the xmonad mailing list