[xmonad] xmobar on GNOME3

Ben Boeckel mathstuf at gmail.com
Wed Nov 28 06:43:47 CET 2012

On Thu, Nov 22, 2012 at 08:07:57 GMT, Tony Morris wrote:
> I am trying to get xmobar running on GNOME3. However, xmonad starts the
> process, then it quits. I am not sure why, but I know that it quits
> because I changed the output handler (ppOutput) to first use writeFile
> then to the xmobar Handle. I saw the contents that would have been piped
> to xmobar in the file.
> If I start xmobar manually after xmonad has started, it starts fine,
> reading "Updating..." awaiting input. I have minimised
> ~/.xmonad/xmonad.hs and I have tried many variants to try to resolve the
> issue:
> https://gist.github.com/4129597
> I have also tried fiddling with ~/.xmobarrc but this is how it currently
> stands:
> https://gist.github.com/4129924
> Any tips are immensely appreciated, because I have run out of ideas!

I use xmonadpropwrite which is what xmonad starts. I've found that it's
much more reliable at starting properly (xmobar doesn't start properly
and consistently without a shell wrapper I have). Since xmobar itself
isn't on the XMonad pipe anymore, I can update my configuration, restart
it, or whatever without having to restart XMonad to get the pipes hooked
up again.

-- Ben

More information about the xmonad mailing list