[xmonad] udiskie+consolekit and still unauthorized access

Rohan Jain crodjer at gmail.com
Thu Mar 15 04:59:17 CET 2012


A similar issue exists for me too. It works if I use gdm3 or lightdm as my
desktop manager, but there are some other issues these window managers pose,
which make them not worth switching to. So, I use xdm. I start xsession using,

    ck-launch-session dbus-launch xmonad

But I still get "Not Authorized" errors with udisks. How do others handle this?

OS: Debian Sid


On 01:56 +0000 / 15 Mar, Robert Sawko wrote:
> Dear All,
> I am a fresh user of xmonad. A month ago I installed Arch and
> decided to give xmonad a try. So far the experience was great and I
> really don't feel like "coming back" at least when it comes to
> personal computer.
> I believe I can already do most of the things I need to do, but now
> I am trying to make the system a bit more convenient. One of the
> things on my todo list is automounting file system
> It has to be said that I got a little bit stuck with that. I would
> like to use udiskie. I read on Arch websites about permissions and
> necessity of installing consolekit.
> https://wiki.archlinux.org/index.php/Udiskie
> I've done that and currently my last line of .xinitrc is
> exec ck-launch-session bash -c "udiskie&  dwm"
> Unfortunately when I run this my log files show only
> failed to mount device /org/freedesktop/Udisks/devices/sdb1: org.freedesktop.Udisks.Error.PermissionDenied: Not Authorized
> What am I doing wrong? I have a feeling that I am missing something important. Have you been able to run xmonad together with udiskie. Any hints or assistance will be greatly appreciated. By the way, are there any better alternatives?
> Robert
> PS I have also checked that the storage option works for me, although CDs are not automounted still.
> _______________________________________________
> xmonad mailing list
> xmonad at haskell.org
> http://www.haskell.org/mailman/listinfo/xmonad

More information about the xmonad mailing list