[xmonad] Can't use any of the contrib modules

Anthony Campbell ac at acampbell.org.uk
Mon Sep 19 18:37:40 CEST 2011

On 19 Sep 2011, wagnerdm at seas.upenn.edu wrote:
> Quoting Anthony Campbell <ac at acampbell.org.uk>:
> >On 19 Sep 2011, Anthony Campbell wrote:
> >
> >getting an "out of scope" error until I replaced defaultTConf with
> >defaultTheme. The xmonad.hs now reads:
> >I think the documentation should  be ameneded to include this change?
> This is exactly what I changed with the patch I pushed (+ a few
> other inconsistencies elsewhere), and exactly the change I suggested
> three days ago (along with several others). Note that the website
> does not show the documentation from darcs xmonad, but from the
> latest release of xmonad. Please "darcs pull", then rebuild the
> documentation locally on your machine to see the change.

Thanks; I knew nothing about darcs but I got it and  ran:

darcs get http://code.haskell.org/XMonadContrib 

This seemed to complete (with some CRC errors which are said not to be
serious) but I think I need to something else to rebuild the
documentation though I don't know what. Probably I'd better give up at
this stage as I'm getting well out of my depth!

Anthony Campbell - ac at acampbell.org.uk 
Microsoft-free zone - Using Debian GNU/Linux 
http://www.acampbell.org.uk - sample my ebooks at

More information about the xmonad mailing list